Questions and answers from the Weglot team


Daanyaal (Customer)

Problem to translate my website

Hello,

I just downloaded your application on Wordpress.
My website is in French, and I would like to add an English version.
I have set everything after watched a tutorial, then the languages flags appear on the main page, but when I click on the English flag it doesn't work, I have a 404 error:

Not Found
The requested URL /en/ was not found on this server.

Can you help me to fix this problem?

In advance thanks,
Best regards

Max (Weglot Support)

Hi,

Thanks for your message.

It seems to be a Permalinks issue. To fix it:
1. Go to your WordPress admin, in Settings > Permalinks
2. Select anything but NOT the first choice ("plain") and make sure you don't have /index.php in your URLs.
3. Save your changes
4. Refresh your web page and it should be working

More info here: [WordPress - Troubleshooting - I see a page not found (404 error) when changing language](https://support.weglot.com/article/76-wordpress-404-error-translating)

You can also check if your rewrite rule module is correctly enabled.
If not, it could be the issue.
In that case, I invite to ask your hosting provider which will tell you how to do.

Let me know if you need help with it.
Have a nice day,

READY TO GET STARTED?
The best way to understand the power of Weglot is to see it for yourself. Get your website multilingual live in minutes.