Questions and answers from the Weglot team


Caelen (Customer)

Error with wordpress plugin

Hello,

We have installed your Weglot plugin on our website, and have added a language (French) but when clicking on the language button, the user is sent to a non-existing page.

Can you please let us know what is wrong with our setup?

Max (Weglot Support)

Hi,

Thanks for your message.

It seems to be a Permalinks issue. To fix it:

  1. Go to your WordPress admin, in Settings > Permalinks
  2. Select anything but NOT the first choice ("plain") and make sure you don't have /index.php in your URLs.
  3. Save your changes
  4. Refresh your web page and it should be working

    Let me know if you need help with it.
    Have a nice day,

Caelen (Customer)

Hi Max, It worked like a charm! Thank you for your help.

Max (Weglot Support)

Hi,

Glad I could help!

If you need anything, don't hesitate to ask me!
Best,

READY TO GET STARTED?
The best way to understand the power of Weglot is to see it for yourself. Get your website multilingual live in minutes.
Cookies settings
We use cookies to collect and analyze information on site performance and usage, to provide social media features and to enhance and customize content and advertisements. Learn more with our Privacy policy
Necessary cookies

Some cookies are required to provide core functionality. The website won’t function properly without these cookies and they are enabled by default and cannot be disabled.

Non-necessary Cookie Settings

Any cookies that may not be particularly necessary for the website to function and is used specifically to remember preferences or to help us improve our website by collecting and reporting information on its usage.

We use cookies to collect and analyse information on site performance and usage, to provide social media features and to enhance and customize content and advertisements. Learn more with our Privacy policy